Обновление кластера Postgre

ERROR: The default postgresql version is not 12 required by libgvmd

Посмотрим, какие кластеры у нас есть:

sudo pg_lsclusters

У меня их сейчас 2. Новый кластер, который был создан автоматически, мы удалим:

sudo pg_dropcluster --stop 12 main

Обновляем старый кластер:

sudo pg_upgradecluster -v 12 11 main

Удаляем старый кластер:

sudo pg_dropcluster 11 main

При желании\необходимсоти удаляем старую версию PostgreSQL:

apt-get remove postgresql-11

Добавить комментарий

Ваш адрес email не будет опубликован.